Probleme mit dem virtuellen WeTab beheben

Das kommt davon, wenn man sich nicht genug Zeit nimmt, Tutorials ausführlich zu testen. Die Installation der virtuellen WeTab Maschine mittels Virtualbox hat ja noch ganz gut funktioniert. Als ich dann aber etwas später auch noch ein paar Sachen mit dem virtuellen WeTab testen wollte, funktionierte zunächst nichts mehr.

Virtualbox zeigte nur einen schwarzen Bildschirm und hat dann die Segel gestrichen. Seltsam, denn ich hatte das virtuelle WeTab schon einmal vor Wochen auf einem anderen Rechner ausprobiert. Da hat es problemlos funktioniert.

Nach endlosen Tests und vielen Installationen und De-Installationen sowie der Suche nach Hinweisen in der WeTab Community habe ich nun endlich einen Weg gefunden, der die bestehenden Probleme, jedenfalls auf meinem Rechner, behoben hat.

Das Grundproblem scheint das neueste Update vom 09. Dezember zu sein. Sobald dieses Update installiert ist, gibt es die entsprechenden Funktionsstörungen. Damit das WeTab grundsätzlich wieder startet, musste ich eine Einstellung in der Virtualbox ändern.

Der erste Start war jedoch nicht von viel Erfolg gekrönt. Denn nun stimmte die Bildschirmdarstellung nicht mehr. Das WeTab wurde viel zu klein dargestellt und lies sich kaum noch sinnvoll bedienen.

Virtualbox Einstellung ändern

Schließlich habe ich einen Hinweis in der Community gefunden, der dieses Problem wieder behebt. Ein weiteres Problem konnte ich jedoch bisher noch nicht zufriedenstellend lösen. In der Root Shell habe ich keine deutsche Tastaturbelegung. Im Moment funktioniert scheinbar nur eine Lösung, bei der man jedesmal einen Befehl eingeben muss, wenn man die Root Shell erstmalig aufruft.

Falls ihr ähnliche Probleme habt, dann könnt ihr nun die nachfolgende Beschreibung nutzen. Wichtig dabei ist, dass ihr möglichst die Reihenfolge der einzelnen Schritte genauso einhaltet. Bei meiner Anleitung gehe ich davon aus, dass das virtuelle WeTab gar nicht mehr oder nur so startet, dass man nichts damit anfangen kann.

Installiert habe ich die Version 4.0 der Virtualbox. Wer ganz sicher gehen will, kann auch noch die alte Version 3.2.8 nutzen. Damit wurde jedenfalls das ursprüngliche Image (vor dem Update) getestet.

Also, der Reihe nach folgende Anweisung befolgen:

  1. WeTab Image neu in die Virtualbox importieren. Davor sollte das ursprüngliche Image aus Virtualbox gelöscht werden.
  2. Systemeinstellung in der Virtualbox ändern. Hierzu in die Settings (“Ändern”) der virtuellen Maschine gehen. Dort “System” auswählen und den Reiter “Beschleunigung” auswählen. Hier habe ich die Hardware-Virtualisierung eingeschaltet.
    Fragt mich aber nicht, warum das geholfen hat. Die Probleme könnten evtl. an dem Prozessor des PCs liegen. In meinem Rechner ist ein Intel Prozessor verbaut. Vielleicht gibt es mit AMD Rechnern keine Probleme.
  3. WeTab starten und zur Sicherheit direkt mal die Root Shell und Gedit installieren. Idealerweise legt man sich beide Widgets noch möglichst weit links auf die Pinnwand.
  4. Update im WeTab durchführen. Aber auf keinen Fall das WeTab neu starten !
  5. Da wir gleich die Root Shell benötigen, gibt es nun einen Befehl, mit der man die deutsche Tastaturbelegung in der Root Shell einschalten kann. Leider funktioniert die permanente Lösung der Community für ähnliche Probleme mit USB-Tastaturen am WeTab nicht. Der Befehl lautet
    setxkbmap -model pc105 -layout de

    Glücklicherweise merkt sich die Root Shell die eingegebenen Befehle bis zu einer bestimmten Anzahl. Bei der nächsten Nutzung der Root Shell gibt man dann am besten die ersten Buchstaben (z.B. “set”) ein und kann dann mit den Hoch-/Runter-Cursor Tasten zu dem Befehl “blättern”.

    Eine Neueingabe ist auch nur nach einem Neustart des WeTab notwendig. Hat man einmal die Einstellung in der Root Shell vorgenommen, kann man diese ruhig wieder verlassen und beim nächsten Aufruf hat man immer noch eine deutsche Tastaturbelegung.

    Für die erstmalige Eingabe des Befehls ist es evtl. gut zu wissen, dass das Zeichen ‘-’ mittels ‘ß’ erreicht wird und dass die Zeichen ‘z’ und ‘y’ vertauscht sind.

  6. Nach dem Update muss eine neue Datei für die Bildschirmeinstellungen angelegt werden. Es wird eine Datei mit dem Namen “80-screen.conf” mit folgendem Inhalt benötigt:
    Section "Screen"
        Identifier  "Screen 1"
        Device      "VESA"
        Monitor     "Generic Monitor"
    
        DefaultDepth 24
    
        SubSection "Display"
            Depth     24
            ViewPort  0 0
            Modes     "1366x768"
        EndSubsection
    EndSection

    Zur Erstellung geht man am besten in die Root Shell und wechselt mit

    cd /etc/X11/xorg.conf.d

    in das Verzeichnis für die Datei. Mit dem Befehl

    sudo gedit

    wird der Editor aufgerufen. Man muss den Befehl als Superser durchführen, da man sonst nicht in das Verzeichnis schreiben kann. Das Passwort für den Superuser in der virtuellen Maschine ist übrigens “wetab“.

    Wer sich das Editieren sparen möchte, dem habe ich hier die entsprechende Datei als Download zur Verfügung gestellt (Download).

    In diesem Fall geht ihr also mit dem WeTab Browser auf meinen Blog (ich nehme doch an, dass ihr diesen sowieso auf dem WeTab lest ;-) ) und ladet die Datei herunter. Eine Besonderheit müsst ihr aber beachten. Das eingebundene WordPress Plugin zur Verwaltung der Downloads öffnet einen Dialog. Im WeTab füllt dieser Dialog den ganzen Bildschirm. Nachdem ihr im Dialog “Download” angeklickt habt, könnt ihr das entsprechende Fenster schließen.

    Nun erscheint die Downloadabfrage des WeTab Browsers. Hier muss der Download nochmals bestätigt werden.

    Anschließend geht ihr wieder in die Root Shell und wechselt in das Download-Verzeichnis (cd Download). Mit dem nachfolgenden Kopierbefehl landet die Datei dann im richtigen Verzeichnis:

    sudo cp ./80-screen.conf /etc/X11/xorg.conf.d
  7. Nun können wir noch die Spracheinstellung des WeTab auf “Deutsch” einstellen. Hierzu gehen wir in den Einstellungsdialog des WeTab und ändern die entsprechende Option. Dieser Schritt sollte auf jeden Fall zum Schluß durchgeführt werden. Nach der Umstellung wird man nämlich aufgefordert, das WeTab neu zu starten.

Mit den oben beschriebenen Änderungen habe ich es bei mir nun geschafft, ein funktionsfähiges virtuelles WeTab zu starten. Lediglich die Audioausgabe funktioniert bei mir immer noch nicht. Ich hoffe, die Anleitung behebt auch bei euch das ein oder andere Problem.

Hat euch der Artikel gefallen? Dann sagt es doch weiter:
  • Print
  • Digg
  • Facebook
  • Twitter
  • Google Bookmarks
  • email
  • FriendFeed
  • Google Buzz
  • MisterWong.DE
  • Webnews.de
  • Wikio
  • Yigg
Dieser Beitrag wurde unter Tipps und Tricks abgelegt und mit , , verschlagwortet. Setze ein Lesezeichen auf den Permalink.

7 Antworten auf Probleme mit dem virtuellen WeTab beheben

  1. Achim Burgdorf sagt:

    Ich habes mit dem Transporter auf die VM gebracht. Da sind Einstellunen etwas feiner und der Kernel ist einstellbar. Ging auch. Allerdings gibt es den Transporter nicht mehr offiziell..

  2. Pingback: Probleme mit dem virtuellen WeTab beheben | Das WeTab Blog

  3. Dieter sagt:

    Funktioniert Super.
    Danke

  4. ubuntu sagt:

    Danke für die Anleitung. Zu dem Ganzen muss ich allerdings bemerken, dass sich Neofonie mal wieder nicht mit Ruhm bekleckert. Mir ist das virtuelle System auch jedesmal nach dem Update abgestürzt und ließ sich nicht mehr starten. Warum bleibt den Neofonie-Leuten dies nur verborgen. Testen die immer noch nicht gründlich, oder sind die zu sehr damit beschäftigt, den Wetab-Besitzern endlich die seit Anfang an versprochenen Funktionen zu liefern? Ich kann doch nicht ein virtuelles Image liefern, das überhaupt nicht nutzbar ist. Welcher Entwickler implementiert denn da noch freiwillig Anwendungen und Apps, wenn das Tool solche Macken hat?

    Gruß
    Ubuntu

    • Jürgen sagt:

      Ja, ähnlich habe ich auch reagiert. Ich war auch erstaunt darüber, dass man grundsätzlich kein neueres Image bereit stellt und dass die Fehler bisher wohl nicht erkannt bzw. nicht behoben wurden. Dabei hätte ich gedacht, dass auch die Entwickler des WeTab u.a. diese Entwicklerimages nutzen. Mir scheint, dass sie immer noch völlig überlastet damit sind, die bisherigen Probleme zu beheben und dadurch bestimmte Dinge nicht bzw. noch nicht umgesetzt werden.

  5. Christian Lempken sagt:

    Hallo und danke für die Anleitung. Funktioniert übrigens auch bestens unter Mac OSX über die VM!!! Nur mal so für die Apfelfreunde die auch mal über den Tellerrand hinaus schauen möchten und sich nicht nur am iPad festbeißen. Bin selbst ein riesen Applefan. Habe mir jetzt aber das WeTab zugelegt um freier zu sein. Muss sagen ich bin bis jetzt super zufrieden.
    Und dank dieser Seite und der Wetab-Community hat man auch fähige Leute die einem bei Problemen weiterhelfen können. Hierfür vielen Dank.
    Viele Grüße, Christian

  6. Pingback: Chrome Web Store auf dem WeTab nutzen – Chrome Installationstutorial | Das WeTab Blog

Hinterlasse eine Antwort

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind markiert *

Du kannst folgende HTML-Tags benutzen: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>